Running bad & lean

Discussion in 'Big Block Cadillacs' started by pila78, Oct 11, 2018.

  1. Red98422

    Red98422 Active Member SUPPORTING MEMBER

    Joined:
    Jun 6, 2018
    Messages:
    144
    Likes Received:
    40
    Location:
    Washington state
    Good lord even the alternator is painted!!!! :eek: :thumbup:

    Wish I could be of help with the carb/ignition issues, but you have surpassed my knowledge by a fair margin. Hopefully some kind soul on this fourm can come up with the answers you need
     
  2. peter phillips

    peter phillips Active Member

    Joined:
    Jun 2, 2011
    Messages:
    260
    Likes Received:
    74
    Location:
    Mississauga Ontario canada
    Hey Bill. Well it was just a thought about the plug wires. I hate getting zapped.
     
  3. PJ McCoy

    PJ McCoy Active Member

    Joined:
    Jul 11, 2015
    Messages:
    999
    Likes Received:
    206
    Location:
    Outter Banks NC
    Bill is the fast idle cam lock working correctly? What is the fast idle rpm at currently? Im also thinking it might not be warmed up and maybe the rear vacuum break no holding the rear air door closed during cold weather conditions. Choke function working correctly?
    Please forgive me if all these have already been looked at. I am brainstorming with you.
    Runs fine in park in gear acts up? Acts up when there is load on the engine. butterfly/transfer slot correct? curb idle correct? is there nozzle drip when the car is in gear?
    hell IDK, maybe its just the "RED THING" under your hood, Just kidding!!;)
    PJ
     
    Darius likes this.
  4. Cad Man

    Cad Man Active Member

    Joined:
    Oct 11, 2018
    Messages:
    153
    Likes Received:
    45
    Location:
    Usa
    Like PJ said if the secondary lock out lever and cam aren't positioned right you have a very tiny 2 barrel carb
     
  5. pila78

    pila78 Well-Known Member

    Joined:
    Dec 1, 2009
    Messages:
    2,766
    Likes Received:
    61
    Location:
    Saginaw michigan area
    No problem with the lock-out or choke mechanisms. Since I keep driving it a bit, I have determined that some debris is under one of the power valve needle jets If I rev it a bit ( it revs up fine) which lets those needles come way up, the fuel seems to be passing through OK (?) Anyway, I'm gonna pull the carb again & check all the passages related to those needles & jets. When I had the carb apart a few weeks ago, I was only looking for crap in the bowl etc, and didn't blow all the passages out like I should have :thumbdown::(o_O
     
  6. Cad Man

    Cad Man Active Member

    Joined:
    Oct 11, 2018
    Messages:
    153
    Likes Received:
    45
    Location:
    Usa
    Bill

    Why not just try the other carb
     
    PJ McCoy likes this.
  7. PJ McCoy

    PJ McCoy Active Member

    Joined:
    Jul 11, 2015
    Messages:
    999
    Likes Received:
    206
    Location:
    Outter Banks NC
    Bill, is this the same carb that plaqued you in the past? If so maybe you can send it off or like Mad said, try another carb. My holley works get. Not the best for fuel mileage but it's fun.
    PJ
     
  8. pila78

    pila78 Well-Known Member

    Joined:
    Dec 1, 2009
    Messages:
    2,766
    Likes Received:
    61
    Location:
    Saginaw michigan area
    Yeah, I have a 750 Holley on the 408 SBC in my Malibu ...runs great, but like you said, it loves fuel !! I'll figure this out eventually, even if it take hauling that carb off a few times ! I don;t like giving up ! The engine ran OK last winter and Spring. Just started raising hell this past summer !!
     
  9. pila78

    pila78 Well-Known Member

    Joined:
    Dec 1, 2009
    Messages:
    2,766
    Likes Received:
    61
    Location:
    Saginaw michigan area
    Oh yeah, there's a '76 Eldo carb on Ebay. It has a different p/n, like 6250 instead of 6230 like mine. It looks rough, though...
     
  10. PJ McCoy

    PJ McCoy Active Member

    Joined:
    Jul 11, 2015
    Messages:
    999
    Likes Received:
    206
    Location:
    Outter Banks NC
    Bill, the amount of gas that the Holly uses in a year over the amount gas "saved" from the Qjet wont be that noticeable within a year. Your not drag racing it. I bet you've already spent more money in your time and parts trying to get the QJet going. If you are drag racing that car on the streets, Then Good for you. You make me happy, Which of course you would need that Holley!

    With all that said, I get the feeling that I am like you, Always need something to "tinker" with. Which means that car is PERFECT!
    PJ
     
  11. pila78

    pila78 Well-Known Member

    Joined:
    Dec 1, 2009
    Messages:
    2,766
    Likes Received:
    61
    Location:
    Saginaw michigan area
    Today, I removed the carb (again) and have it apart on the bench. I noticed a bit of sand type debris in the float bowl. My filter is an after market type, that has just a screen in it. Not sure that the sand/grit stuff could affect the way it runs, but I bought an OEM type paper inlet filter I ordered some gaskets and a new inlet fitting from Q-jet Parts.com The inlet fitting has some surface rust in it. I could chuck it up & get it cleaned up in there, but elected to get a new one.. Something else is ailing this engine though. Feels like it's actually missing a cylinder at idle (?) Weird.. Anyway, one disaster at a time !!;)
     
  12. pila78

    pila78 Well-Known Member

    Joined:
    Dec 1, 2009
    Messages:
    2,766
    Likes Received:
    61
    Location:
    Saginaw michigan area
    I Have the carb back on, after an extensive inspection & cleaning........it still runs like shit. Idles good though !!;) I have to think that the fuel level in the bowl isn't where it belongs. And, the problem could still be something funky in the ignition, even though it revs fine if the rpm is high enough to clear itself...
    The missing & roughness starts immediately off idle. Pump squirter make a decent shot of fuel... More fun to come I guess....
     
  13. pila78

    pila78 Well-Known Member

    Joined:
    Dec 1, 2009
    Messages:
    2,766
    Likes Received:
    61
    Location:
    Saginaw michigan area
    I believe my next move is removing the hoses on the fuel line, front & rear, blowing out the line, and replacing the hoses. Have to eliminate any any source for the problem, so the fuel supply is next..
     
  14. PJ McCoy

    PJ McCoy Active Member

    Joined:
    Jul 11, 2015
    Messages:
    999
    Likes Received:
    206
    Location:
    Outter Banks NC
    Bill What size rods and jets are you using? Mine are Jets 70 rods 40
    Ive upgraded the jets to 72 with 40 rods, will give me better full throttle but might be a bit rich on the cruise side. According to Lars paper My engine would do well with 72 jets and 44 rods, Giving me close to the same cruise ratio as stock but 10% increase in total fuel at WOT.
    PJ
     
  15. pila78

    pila78 Well-Known Member

    Joined:
    Dec 1, 2009
    Messages:
    2,766
    Likes Received:
    61
    Location:
    Saginaw michigan area
    I guess I don't know much about what the hell is going on with this engine. This evening, I had to go for an IV at the hospital ( twice a day for a kidney infection) and on the way there it acted up a bit as usual.
    On the way home, it came on without any burping, backfires etc at all ! Have to see how it acts tomorrow when I go in for another IV. When I assembled the carb this time, I used an OEM paper filter in the carb inlet fitting, to catch the fine stuff I found in the bowl this time.

    In other things, I bought another Q-jet carb off of Ebay, for #39.95 ...shipped ! It arrived today. It's supposedly for a '76 Eldo engine. (?) but it's similar to the one I'm using... Not gonna fool with it until the current problem goes away...

    PJ...the needles & jets are from a so-called tuning kit from Cadco. I didn't check the P/Ns on them yet...
     
  16. PJ McCoy

    PJ McCoy Active Member

    Joined:
    Jul 11, 2015
    Messages:
    999
    Likes Received:
    206
    Location:
    Outter Banks NC
    Sounds like rusty tank or lines. If it went from bad to good then back to bad. I would also check the tank and lines. One a different note.
    Your in my thoughts and prayers for the kidney issue.
    PJ
     
  17. Darius

    Darius Well-Known Member SUPPORTING MEMBER

    Joined:
    Oct 15, 2004
    Messages:
    3,888
    Likes Received:
    422
     
    PJ McCoy likes this.
  18. pila78

    pila78 Well-Known Member

    Joined:
    Dec 1, 2009
    Messages:
    2,766
    Likes Received:
    61
    Location:
    Saginaw michigan area
    This morning the engine ran OK, and even laid some rubber when I leaned on it a little.. It does have a miss I believe, which makes it idle strange. It never quits at idle, but shakes evenly, like one cyl isn't working. Have to get into that problem next.. Can't feel the "miss" above idle RPM though...

    PJ...the tank and lines are new, from when I did the body-off resto a few years ago...
     
  19. PJ McCoy

    PJ McCoy Active Member

    Joined:
    Jul 11, 2015
    Messages:
    999
    Likes Received:
    206
    Location:
    Outter Banks NC
    Gotcha! I had forgotten about that Bill.
     

Share This Page