Oil pump

robocop

Active Member
Joined
Oct 14, 2004
Messages
210
Reaction score
26
Points
28
Location
Miami, Florida
What vehicle(s) do you drive?
1987 Cutlass Supreme 2 door with 500 Cad/Turbo 40
I think I have a bad rod bearing in my 500. At low rpm there is no noise but there is a loud rapping at higher rpms. I did hammer it a lot and I have a stock 35lb pump. It has the MT10 cam and would pull hard to 4800 rpm. I did that a lot. So I'll be pulling the engine and might as well get a high psi pump. Which one fits in the G body chassis so I don't have to use the remote filter set up? I've found it only costs me maybe 2 psi but I want to get rid of it anyway. Application is a 87 Cutlass.
 

Big Cadoo!

Member
Joined
Sep 15, 2021
Messages
56
Reaction score
14
Points
8
What vehicle(s) do you drive?
Allegro
I think I have a bad rod bearing in my 500. At low rpm there is no noise but there is a loud rapping at higher rpms. I did hammer it a lot and I have a stock 35lb pump. It has the MT10 cam and would pull hard to 4800 rpm. I did that a lot. So I'll be pulling the engine and might as well get a high psi pump. Which one fits in the G body chassis so I don't have to use the remote filter set up? I've found it only costs me maybe 2 psi but I want to get rid of it anyway. Application is a 87 Cutlass.
I drill and tap the pipe plug from the oil pump 3/8-24. Then taper the hex side of plug for oring. Take a 3/8-24 nylons nut and thread it on the bolt backwards. Machine lip on bolt for spring location. Install oring on bolt after nut is threaded on. Then thread into pipe plug. Install in oil pump. Set oil pressure by threading in bolt. Tiighten nut to secure. Oring seals in taper of pipe plug.
 

Big Cadoo!

Member
Joined
Sep 15, 2021
Messages
56
Reaction score
14
Points
8
What vehicle(s) do you drive?
Allegro
I think I have a bad rod bearing in my 500. At low rpm there is no noise but there is a loud rapping at higher rpms. I did hammer it a lot and I have a stock 35lb pump. It has the MT10 cam and would pull hard to 4800 rpm. I did that a lot. So I'll be pulling the engine and might as well get a high psi pump. Which one fits in the G body chassis so I don't have to use the remote filter set up? I've found it only costs me maybe 2 psi but I want to get rid of it anyway. Application is a 87 Cutlass.
My method of Oil Control.
 

Attachments

  • 20210923_130250.jpg
    20210923_130250.jpg
    344 KB · Views: 8
  • 20210923_153629.jpg
    20210923_153629.jpg
    175.3 KB · Views: 8
  • 20210917_113748.jpg
    20210917_113748.jpg
    140.1 KB · Views: 7
  • 20210915_103412.jpg
    20210915_103412.jpg
    255.2 KB · Views: 6
  • 20210915_103210.jpg
    20210915_103210.jpg
    222.2 KB · Views: 6
  • 20210915_103518.jpg
    20210915_103518.jpg
    291.7 KB · Views: 7
Top